ubuntu firefox提示已阻止使用早期版本的flashplayer

升级到15.10后,ubuntu仍然没有内置升级firefox的flash插件,不得不采用手动升级来解决弹出“已阻止使用早期版本的flashplayer”的提示。

如果我们按照弹出提示进行升级,会发现,升级会打开软件中心,但是软件中心的flash版本确实还很低所以不能靠软件中心来升级。我们进到 https://get.adobe.com/flashplayer/ ,选择下载linux tar.gz包,下载下来以后解压出来,你会看到一个.so和一个usr目录。

cd到解压的目录,执行下面两条命令,来把文件复制到对应的目录去:

>> sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
>> sudo cp -r ./usr/* /usr/

重启firefox,即可使flash成为最新版本,打开优酷之类的网站,可以直接启用flash,不需要激活。

2015-11-01